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|. SET UP PDF, PRINTER FRIENDLY, AND XML

CONFIGURATIONS

With the simple demo site integrated, you want to take advantage of more system functionality and

set up a PDF, printer friendly, and XML version of the pages. The first thing you need to do is set

up the publishing targets. New targets are needed to specify a new type of page output. The target

used in the previous two technical documents was an HTML target, and the pages associated

used a HTML output. Now, you need to setup targets that have different output types.

Target
(HTML)

Target
(Printer
Friendly)

Template
(HTML)

Template Configuration

(Printer Set
Friendly) (Standard)

Template
(PDF)

First, you will create a PDF target.

A. Create a PDF Target

To set up a PDF target:

1. Go tothe Administration area, and select Targets & Destinations

bar.

Click on the web target, and then click New Target .

For the Name field, type in pdf.

Page
(Privacy
Policy)

from the left navigation

For the Base Folder field, select the top-level folder of the specific site being managed. In

our case, we will use /web.

5. For the Output File Extension field, type in .pdf.
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6. For the Type of Data field,
select PDF from the drop down.

7. For the Internal Links option,
check the box for Include
Target Path . This field lets the
system know that the path of
the target should be part of the
publishing output folder and
that the links should have this
path taken into account.

8. Click Submit to save the new

target.

Now with the new target in place, you need to set up a destination to have the PDF content

published.

To set up a destination:

1. Click on the new target located in the asset tree, in the left navigation bar. In our case, we
will select /web/pdf .

Click New Destination .

3. For the Name field, type in
Local .

4. For the Transport field, select
an existing transport. In our
case, we will select
Filesystem followed by
Server Hard Drive .

5. Select all groups in the
Applicable for Groups field,
and click the green arrow to
have the selected items
moved to the box on the right.

6. Now click the Submit button to save the new destination.
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B. Create a Printer Friendly Target

With the PDF target and destination in place, you want to set up a similar one for printer friendly.

To set up a printer friendly target:

1.

While still in the Administration area under Targets & Destinations , click on the web
target, and then click New Target .

For the Name field, type in printer .

For the Base Folder field, select the browse icon and choose the main asset folder for the
site. In our case, we will select /web.

For the Output File Extension field, type in .html .

Check the Internal Links box for Include Target Path .

Click the Submit button to save the new target.

Now set up a new local destination for the printer target in the same way it was completed

previously for the pdf target. With a printer friendly target and destination in place, you need to set

up the final XML target.

C. Create an XML Target

To set up an XML target:

1.

w

N o 0o bk

While still in the Administration area under Targets & Destinations , click on the web
target, and then click New Target .

For the Name field, type in xml.

For the Base Folder field, click the browse icon, and select the main asset folder for the
site. In our case, we will select /web.

For the Output File Extension field, type in .xml.

For the Type of Data field, select XML from the drop down.

Check the Include Target Path box for Internal Links .

Click the Submit button to save the target.

Now set up a new local destination for the xml target in the same way it was completed previously

for the pdf target.
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D. Create a PDF Template

With the three targets in place, you are ready to set up the new templates. The first template you

want to set up is for PDF generation.

To set up the PDF template:
1. Go tothe Home area, and browse to your templates folder. In our case, we will use
Iweb/templates .
Click New -> Default -> Template in the top navigation menu.
For the XML field, please type in the following:
<html|>
<head>
<title></title>
</head>
<body>
<!I-- #BeginEditable name="PDF-HEADER" -->
<h1>The PDF Header</h1>
<!I-- #EndEditable -->
<system-region name="DEFAULT" />
<!I-- #BeginEditable name="PDF-FOOTER" -->
<p>The PDF Footer</p>
<l-- #EndEditable -->
</body>
</html>
4. Check the box Convert HTML to
XHTML. This automatically creates
XHTML blocks for the PDF-HEADER
and PDF-FOOTERregions and puts
in additional fields in the <head>
portion of the template.
5. Now select the System pane. For
the System Name field, please
enter pdf.
6. For the Target field, please select

your new PDF target. In our case, we will select /web/pdf .
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7. Now select the Regions pane. For the Stylesheet field, click the browse icon, and select
/common/stylesheets/output/xhtml2fo2pdf . For this example PDF template, you're
actually just producing HTML and having the HTML converted to XSL:FO and then
transformed into PDF. You can generate PDFs directly from XML without going through
HTML, but for the purposes of this example, it is easier to first use HTML. Please see
Google for more information about XSL:FO and the powerful capabilities it provides.

8. Now click the Submit button to save the new template.

E. Create a Printer Friendly Template

With the PDF template in place, you need to create the printer friendly template.

To create the printer friendly template:
1. Browse to the templates folder for the site. In our
case, we will use /web/templates .
2. Select New -> Default -> Template from the top
navigation menu.
3. For the XML field, please type in:
<html>
<head>
<title><system-page-title/></title>
</head>
<body>
<!-- #BeginEditable name="PRINTER-HEADER" -->
<h1>The Printer Friendly Header</h1>
<l-- #EndEditable -->
<system-region name="DEFAULT" />
<!-- #BeginEditable name="PRINTER-FOOTER" -->
<p>The Printer Friendly Footer</p>
<!-- #EndEditable -->
</body>
</html>
Check the box that says Convert HTML to template XHTML
Now select the System pane. For the Name field, type in printer friendly .
For the Target field, select the new printer friendly target created earlier. In our case, we

will select /web/printer .
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7.

Click the Submit button to save the template.

Now with the PDF and printer friendly templates in place, you need to create the final XML

template.

F. Create an XML Template

To create an XML template:

1.
2.
3.

6.

Select the templates folder for the specific site. In our case, we will select /web/templates .
Click on New -> Default -> Template in the top navigation menu.

For the XML field, please type in:
<xml>
<metadata>
<title><system-page-title/></title>
<description><system-page-description/></descri ption>
<keywords><system-page-keywords/></keywords>
</metadata>
<main-content>
<system-region name="DEFAULT" />
</main-content>

</xml>

Now select the System pane. For the System Name field, type in xml.

For the Target field, please choose your XML target created previously. In our case, we will
choose /web/xml .

Now click the Submit button to save the new template.

With the three templates and targets in place, you only need to add the templates to the page

configuration set in order to see the new content formats.

G. Attach Templates to a Configuration Set

To add new configurations to a configuration set:

1.
2.

Go to the Administration area, and select Configuration Sets from the left navigation bar.
Select the specific configuration set for the site. In our case, we will choose the Web
Standard configuration set.

Click the Edit tab, and select the Configurations pane.

Scroll down past the default configuration to the section labeled Add.

For the Template field, click on the browse icon to choose your new PDF template. In our

case, we will choose /web/templates/pdf .
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6. For the Name field, type in PDF.
7. Click Add this new configuration
8. You will be forwarded to the
properties for the new
configuration (located under
the Configurations pane, in
the Edit tab), which includes
the regions it has inherited
from the template. Click
Submit to save the
changes.
9. Repeat this process two
more times creating the
Printer Friendly and XML
configurations with
corresponding templates.
With the configuration set updated, you can go to your pages and preview the content repurposed
for the newly set up output formats. Your final task is to make the different page formats available

as links on the standard HTML configuration.

H. Configuration Hyperlinks from a Template

When a page has multiple configurations, you need a way to navigate between them. A simple
system-page-output attribute can be placed inside of conventional HTML anchor tags in order
to enable end users to switch between different configurations for a page via standard hyperlinks.

These hyperlinks will be accessible both within the system and on published page(s).

To link other configurations within a configuration set from a template (or any other XML/XHTML):
1. Go to the Home area, and browse to the standard HTML template used for the pages. In
our case, we will select /web/templates/standard
Click the Edit tab.
3. Create a standard HTML anchor tag without any attributes for your desired configuration. In
order for the system to find the desired configuration, use the system-page-output
attribute with the name of your target matching the target used in the designated

configuration. In the XML field, after the <body> tag, find the place you want the links to
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appear and insert the following code:
<p>

<a system-page-output="pdf">PDF</a> |

<a system-page-output="printer">Printer Friendly< la> |

<a system-page-output="xml">XML</a>
</p>
This code represents three link tags, each with a special system attribute that points to a
unique target used by the chosen configuration set. The system will automatically remove
this attribute and will insert in its place a correct href attribute.
The value of the attribute is the name of the target and should not be confused with the
name of the particular configuration. In the “XML" output, even though the configuration is
named “XML,” the system looks for the unique name of the target, which has also been
named “xml.” The special system-page-output attribute is only valid for page
configurations that are contained within the same configuration set (i.e. an XML
configuration from another configuration set has to be linked in a different manner).
Note: If you don’t know where the code should go, just put it after the opening <body> tag.
Additionally, these link values can also go into a block or stylesheet in a template region so
that only certain pages make them available (e.g. press releases).

4. Click the Submit button to save the template.
Now, your pages are ready to go

with links to the available

formats.

10
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II. CREATE AND ASSOCIATE WORKFLOWS

Cascade Server ensures that content entered into the system is quality checked by mandating that
the entered content go through a series of approval steps. These steps can be configured through
the web interface by creating a Workflow. The workflows are managed in the Administration area

of the application and are defined as XML.

With your site content and formats in place, you want to set up a specific workflow for content
changes. Workflow definitions can either be built visually or by hand using XML. You want to
create a simple workflow visually. Like data definitions, workflows are defined as XML in the
system area. Unlike data definitions, where the XML is transformed by the system to produce a
form field in which a user enters data, the workflow definition is used by the system to move assets
along in a quality assurance process. The steps below detail how to create and use standard

workflows.

Asset Factory

(Press

Release)

y
v

A. Create a Workflow Visually

To create a new workflow visually:
1. Inthe Home area, select the folder /common/workflow builder . In this folder, there are
pages that represent parts of workflows and complete workflows.

2. Select the page 1 step. In the Layout view, you can see the steps and actions.

11
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N o g ko

10.

11.

12.

13.

14.

15.

16.
17.

Select the Copy tab.
For the System Name field, type in My Edit Workflow .
Click the Submit button to create the copy.

Now select the Edit tab on the resulting page.

You now have the data definition interface showing multiple steps. For the second step,

change the Step Name to Final Review . In this interface, you can add and delete as many

steps as necessary, assigning the appropriate user to each step.

Click Submit to save the updated workflow.

Now that you are back on the View tab, select the XML output. View the source of the XML

by right-clicking your mouse on the XML screen, selecting This Frame , and then selecting

View Frame Source . Highlight the XML and copy it by pressing Ctrl-C.

With that XML copied, you need to go into the Administration area in order to create the

actual workflow definition.

In the Administration area, select
Workflow Definitions from the left
navigation bar.

Click on New Workflow Definition
For the Name field, type in Edit
Asset Workflow .

For the Workflow Type , check Edit
(you will also have to uncheck
Create, which is checked by
default).

Select all of the Applicable

Groups, and click the green arrow
to move them into the box on the

right.

For the XML field, press Ctrl-V to paste your previously copied XML.

Click Submit to save the new workflow definition.

12
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B. Attach a Workflow Definition to a Folder

With your new workflow created, you need to attach it to a folder.
To attach a workflow definition to a folder:
1. Go back to the Home area and browse to a folder where you would like the workflow
enforced. We will choose our main site folder /web.
Click the Workflows tab.
3. For the Add Workflow label, click the browse icon and select the workflow you just created
— Workflow Definitions/Edit Asset Workflow
4. Click the Submit button to save the changes to the folder.
The workflow definition is now attached to the folder. This means that an action taken on any asset
in that particular folder will trigger the workflow process related to that action. For example, if a
page is edited in that folder, an ‘Edit’ workflow associated with that folder will be invoked. Unless
workflows are turned off at the folder-level or a user has bypass workflow permissions (based on
user roles), users may not edit an asset in that folder without it passing through the selected

workflow.

To test it out, edit a page in the folder without bypassing the workflow process.

C. Edit a Page without Bypassing the Workflow Proce  ss

To edit a page without bypassing the workflow process:

1. Browse to a page for testing. We will select /web/example .

2. Click the Edit tab.

3. Click on the System pane.

4. Click on Advanced Options, and check the box that says Start Workflow (boxes that are
already checked, should remain checked). Note that this checkbox only appears unchecked
for users with bypass privileges. The checkbox will be inactivated all for other users.

Click the Submit button to trigger the workflow screen.

If there were other workflows attached to the folder, you would be forwarded to an
Available Workflows screen. Since you only have one workflow available, you are
immediately forwarded into the Active Workflow screen, which is labeled Start Workflow:
Edit Asset Workflow

13
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7. In the Workflow Name field, you will see the name of the workflow definition you created.

This can be customized to
describe this particular workflow.
Type in My First Workflow .

8. Click the Submit button to start
the workflow.

9. The server will trigger an email
to the next user or group in the
workflow process (assuming the
SMTP has been previously set
up correctly under Tools ->
Preferences -> Email ).

Now, if you are logged in as the user

admin, you'll see the new workflow appear on your dashboard. To go to your dashboard, click on

Home in the top navigation menu. You can click on the new workflow from the dashboard or click

on the Workflows tab, and then select the workflow to enter the active workflow screen and finish

it out.

You can create as many
workflow definitions as needed
and attach them to different
content folders and asset
factories. Multiple workflow
definitions ensure the right
structured approval process
takes place for different types of

content.

14
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[Il. DISPLAY RECENT PRESS RELEASES

A common use of the system is to show the most recent press releases issued on a site. The

demo site doesn’t have a press releases section, but we’ll go ahead and create a temporary

example walking through the process. The first step is to set up an index block of the press

releases folder.

A. Create an Index Block of Press Releases

To create an index block of press releases:

1.

ok wDN

o

First create the press releases folder (refer to Technical Intro Part 1 on How to Create a
New Folder). In our case, we will create /web/press-releases .

Browse to your index blocks folder. In our case, we will browse to /web/blocks/index .
Click on New -> Default -> Block in the top navigation menu.

Select the Index Block radio button, and click Submit .

For the Index Folder field, browse to your press releases folder. In our case, we will
choose /web/press-releases . Click Confirm to approve the selection.

For the Depth of Index , type in 1.

For the Index Asset Types , check the box for Pages.

For the Index Asset Content , check the boxes for Regular Content and User Metadata .

15
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9. Now go to the System
pane. For the System
Name field, type in press
releases.
10. Click Submit to save the
new press releases index
block.
11. The new index block
won’t have any content if
there aren’t any pages in
the designated folder.
Copy several pages into
your press releases
folder . In our case, we
will copy /web/about and /web/agents into /web/press-releases . Note that pages used in
an index block need to have the option Include when indexing turned on in the respective
page system menu choices, otherwise they won’t show up in the index blocks.
12. With the pages copied in, navigate back to your press releases index block. In our case, we
will navigate to /web/blocks/index/press releases . You should now see the page

metadata in the XML preview.

B. Create a Recent Press Releases Stylesheet

Now that the index block and the pages are in place, you need to create a new XSL in order to

transform the XML into our desired snippet of HTML.

To create a recent press releases stylesheet:
1. Browse to your stylesheets folder. In our case, we will browse to /web/stylesheets .
2. Click on New -> Default -> Stylesheet in the top navigation menu.
3. For the XML field, type in the following:
<xsl:stylesheet version="1.0"
xmins:xsl="http://www.w3.0rg/1999/XSL/Transform">
<xsl:output method="xml" indent="yes" />
<xsl:template match="system-index-block">
<div><h2>Recent Press Releases</h2>

<xsl:apply-templates select="system-page" / >

16
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</div>

</xsl:template>

<xsl:template match="system-page">
<xsl:if test="position() &lt; 5 and name !=" index">
<p>
<a>
<xsl:attribute name="href">
<xsl:value-of select="path" />
</xsl:attribute>
<xsl:value-of select="title" />
</a><br />
<xsl:value-of select="summary" />
</p>
</xsl:if>
</xsl:template>
</xsl:stylesheet>
The stylesheet outputs a heading, saying recent press releases, and then matches all of
the system pages. If the page is one of the first four in the folder, according to the folder
positioning, and isn’t the index, then a link is created to the press release with the title

metadata value and then the summary metadata value is shown below.

4. Click on the System pane; and for the System Name field, type in recent press releases .

5. Click on the Submit button to save the new stylesheet.

C. Override a Region at the

Page Level

Now that you have your press
releases index block and stylesheet,
you need to plug them in to a page
region. You are going to override the
context navigation region specified
by the configuration set with your

recent press releases.

17
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To override a region block and stylesheet at the page level:

1.
2.
3.

Browse to the desired page. In our case, we will choose /web/index .

Click the Edit tab.

Select the Configurations pane in order to see the existing configurations. Because
HTML is the default configuration, it will already be shown in the pane along with all
available regions and any current assignments.

Click the browse icon for the CONTEXT-NAVIGATION Block, and select your new press
releases index block. In our case, we will select /web/blocks/index/press releases

Now click the browse icon for the CONTEXT-NAVIGATION Stylesheet, and select your
new recent press releases stylesheet. In our case, we will select /web/stylesheets/recent
press releases .

Now click Submit to save the page.

The resulting page shows the new

recent press releases area,

displaying the appropriate press

release links. In our case, the about

and agents pages appear. However,

no summary shows up below the

links, because that field is not filled

out on the page metadata. We go

into the press releases folder and put

in summary metadata for both pages.

We then go back to the index page

and everything looks great. The

recent press releases stylesheet

should be customized further to fit in

with your site look-and-feel, but this provides a nice starting point.

18
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Thanks for going through Part 3 of the Technical Introduction. Part 4 is available online:
Learn how to use external links, set up RSS feeds, and create advanced data
definitions.

http://hannonhill.com/downloads/pdf/contentxml/Technical Intro 4.pdf

Please let us know if we can answer any questions.
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