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|. CONTENT RE-USE

Often times it is necessary to re-use content in numerous places on a site. A common example is
having a privacy policy stored in a single location that is re-used across several subsidiary sites

with an independent look-and-feel.

Stylesheet Template Page
(Subsidiary (Subsidiary (Subsidiary

A) A) A)

|
|

You want to go through three different ways this can be accomplished in the CMS. Data definition
pages in the CMS can include the content of one or more other pages in the system via a data
definition page chooser. The first thing you need to do is create a new data definition with the page

chooser.

A. Data Definition with Page

Chooser

To create a data definition with a page chooser,
please do the following:

1. Go to the Administration area, and
select Data Definitions in the left
navigation bar.

Click on New Data Definition .

3. For the Name field, type in place page .
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For the XML field, type in:
<system-data-structure>
<asset identifier="page-content" type="page" mul tiple="true"
label="Page Content" required="true"
render-content-depth="unlimited" />

</system-data-structure>

Click Submit to save your new data definition.

B. Copy Page and Attach Data Definition

Now, with your simple place page data definition complete, you need to attach it to a page.

To copy a page and attach a data definition to the new page:

1.

ok~ b

© © N O

11.

12.

Go back to the Home area.

Click on the desired site in the left asset tree. In our case, we will select our web folder.
Click on an existing page. In our case, we will select the agents page.

Select the Copy tab.

For the new page name, just add the number 2 after the existing name. In our case, we will

put in agents2 .

Click Submit to copy the page.
Now, you'll be on the new, copied page. Select the Edit tab.
On the System pane, check the box that says Use Data Definition.
Now click the browse icon for the Data Definition label, and select /place page as the data
definition.
. Click Submit to save the page.

Now click the Edit tab again, and
you’ll see the data definition attached
to the page.

In the data definition, click the browse
icon for the Page Content label and
browse for the original page that this
copied page was made from. We will
select /web/agents as our page.
Click Confirm to record the page

selection.
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13. Now click Submit to save the page change.

In the resultant page, you will see the contents of the page selected. If you go and change the

original page, the changes will be reflected in this new page. In addition to the page contents,

different metadata values also show up at the very bottom because they were supplied by the

system XML when using the page chooser.

C. Filter Metadata with XSLT

Now, you want to write a simple XSLT that will just show the page content and ignore the

additional fields.

To create an XSLT that filters out metadata and only displays the page content, please do the

following:

1.
2.

Please select your stylesheets folder. In our case, we will select /web/stylesheets .
With the folder selected, please click on New -> Default -> Stylesheet in the top navigation
menu.
For the XML field, please type:
<xsl:stylesheet version="1.0"
xmins:xsl="http://www.w3.0rg/1999/XSL/Transform">
<xsl:output method="xml" indent="yes"/>
<xsl:template match="/system-data-structure">
<div>
<xsl:copy-of select="page-content/content/ node()"/>
</div>
</xsl:template>
</xsl:stylesheet>

Go to the System pane, and for the
System Name field, please type place
page.

Click Submit to save the new stylesheet.
Now, in the left asset tree, select the
page created earlier that has the data
definition. We will select /web/agents2 .
Select the Edit tab, and choose the
Configurations pane.

You will automatically be forwarded to the

HTML configuration.
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9. Under the DEFAULT region, click the browse icon to select /web/stylesheets/place page
for the Stylesheet . The block can be left blank for the default region, because it will
automatically be populated with the XML output from the data definition.

10. Click Submit to save the configuration changes.

When the resulting screen loads, you will see the placed page content with the metadata values
removed. In addition to having the page chooser in the data definition, you could extend the place
page data definition in order to allow for more pages or other data capture fields. Having the page

chooser in the data definition makes it easy to re-use content across a site or even multiple sites.

D. Data Definition with Block Chooser

Now, you want to go through an example that is similar to the page chooser, only this time we’'ll
use a block instead. The first step is to set up a new data definition that allows for inserting a
block.

To create a data definition with a block chooser, please do the following:
1. Go to the Administration area, and
select Data Definitions from the left
navigation menu.
Click on New Data Definition .
For the Name field, type in place
block .
4. For the XML field, type in:

<system-data-structure>
<asset identifier="block-
content" type="block"
multiple="true" label="Block
Content" required="true" />
</system-data-structure>

5. Click the Submit button to record

the new data definition.
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E. Create a New Text Block

With your data definition in place, you need to create a new block to be used in the block chooser.

To create a new text block:

1. Go back to the Home area.

2. Click on your desired site and folder in
the left asset tree. In our case, we will
select /web/blocks .

3. From the top navigation menu, select
New -> Default -> Block .

Select Text Block , and click Submit .
For the Text, please type in This is an
example block .

6. Under the System pane, type in
example block for the System Name .

7. Click the Submit button to save the

new block.

F. Copy Page and Attach Data Definition

Now that your block is ready, you need to attach the new data definition to a page and then

choose the new block.

To copy a page and attach a data
definition:

1. Please select an existing page. In
this case, we will choose the
/web/about page.

2. Click the Copy tab, and type in a
System Name for the new page. In
this case, we will use the value
about2 as our system name.

3. Click Submit to create the copy.
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4. Now, on the resultant page, click the Edit tab and select the System pane to see the page
options.

5. Check the box for Use data definition.

6. Click the data definition browse icon to choose the /place block .

7. Click Submit to record the page change.

8. Now click the Edit tab to use the newly attached data definition.

9. Click the browse icon next to the Block Content label.

10. Select the newly created block. In our example, we will select /web/blocks/example block

11. Click Confirm to record the selection.

12. Now click Submit to save the page changes. On the resulting screen, you'll see the

contents of the block, which are displayed inline on the page with metadata.

Data definitions can have multiple page and block choosers, providing an easy way to re-use

content in a variety of different ways.

G. Index Block with Inline Page Content

In addition to manually selecting individual pages and blocks to re-use, index blocks can be
configured to include the contents of pages and blocks, which provide another mechanism to re-
use content in an automated way. For example, if you have a folder of articles, you can use an
index block to retrieve all of the contents of the folder and then use XSL to show the content
heading with a “read more” link that takes the user to the full article. The first step is to create a

new index block that points to the desired folder and includes the contents inline.

To create a new index block with inline
page contents:

1. Browse to the desired folder in the
system. In our case, we will select
/web/blocks as our example.

2. Click on New -> Default > Block
in the top navigation menu.

3. Select Index Block, and click
Submit .
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4. For the Index Folder , click the browse icon and select a folder in the system. In our case,
we will select /web from the chooser, and click Confirm to record the selection.

5. For the Depth of Index field, type in the number 1. This will cause the index block to only

return the contents of that folder and not its sub-folders.

For the Indexed Asset Types , check the box for Pages

For the Page XML select the radio button for Render page XML inline .

For the Index Asset Content , check the boxes for Regular Content and User Metadata .

© © N ©

Go to the System pane, and for the System Name field, type in page listing .

10. Click Submit to save the new index block.

On the resulting screen, you will see the XML output for the new index block.

H. XSLT to Filter Index Block with Page Content

With your new index block in place, the next step is to take the XML output and use it in your
desired XML/XSL IDE to write a corresponding XSLT.

To create a new XSL to filter the XML output:
1. Inyour browser, do a view source of
the XML frame from the page listing
index block (by right clicking on the
mouse, selecting This Frame and
then selecting View this Frame ) and
copy the XML into your XML/XSL
IDE. We will copy it into the XML tab
in Cooktop on Windows
(XMLCooktop.com). In our XML/XSL
IDE, we will write our XSLT and test it
before bringing it into the CMS.
In the CMS, browse to your stylesheets folder. We will select /web/stylesheets .
On the top navigation menu, select New -> Default -> Stylesheet .
For the XML field, please type in the following:
<xsl:stylesheet version="1.0"
xmlns:xsl="http://www.w3.0rg/1999/XSL/Transform">

<xsl:output method="xml" indent="yes" />

<xsl:template match="system-index-block">
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<div>
<xsl:apply-templates select="system-page" />
</div>
</xsl:template>
<xsl:template match="system-page">
<p>
<xsl:if test="page-xhtml/h1">
<xsl:value-of select="page-xhtml/h1" />
<br />
<a href="{path}">Read more...</a>
</xsl:if>
</p>
</xsl:template>
</xsl:stylesheet>

5. Go to the System pane and, for the System Name field, type in page listing .

6. Click Submit to save the new stylesheet.

I. Copy Page, Associate Block and Stylesheet

With your index block and stylesheet finished, the final step is to copy a page and associate the

new assets.

To copy and associate a block and stylesheet with a page:

1. Browse to an existing page. In our case, we will select /web/contact .

2. Click on the Copy tab, and type in a new name for the copied page. In our case, we will call
our page contact2 .
Click Submit to make the page copy.
On the resulting page, click the Edit tab and select the Configurations pane in order to
display available configurations.
You will automatically be forwarded to the HTML configuration.
Under the DEFAULT region, click the browse icon to select /web/stylesheets/page listing
for the Stylesheet .
For the Block, click the browse icon to select /web/blocks/page listing

8. Click Submit to save the configuration changes.

10
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9. Now, we want to put in a message to any system user who might potentially edit the page
that the default block and stylesheet have been overridden. Click the Edit tab, and select
the System pane to show the page options.

10. Check the box for Use Data Definition .

11. For the first Data Definition label, click the browse icon and select /placeholder . This
displays a simple text box notifying a user that clicks edit on the page that the default
region has been overridden with
a block.

12. Now click Submit to save the

page changes.

Now, in the main content region, you
will see dynamic output re-using
content from the pages in the folder in
order to create an article listing of the
page heading with a link to read more.
Index blocks make it easy to
incorporate content from anywhere in
the system for placement anywhere in

the system.

11
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lI. SCRIPTING LANGUAGES

Content from the system can be published as files with any desired file extension. For example,
from a single content repository multiple sites can be managed, each with a different scripting
language like ASP, ASPX, PHP, CFM, SSI, and JSP. The system supports managing content that

is published to multiple servers in a non-heterogeneous environment.

Template Publish
(ASP) Server

1s)

|
|

The first step for publishing content with a specific file extension is to modify the publish target.

A. Change Target Output File

Extension

To change the target output file
extension:

1. Go to the Administration area,
and select Targets &
Destinations from the left
navigation bar.

2. Select the desired target from the
left navigation bar. In our case,
we will choose the /web target.

3. Click on the Edit tab.

12
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4.

5. Click the Submit button to save the updated target.

With a target set to publish files in a designated extension, the next step is to incorporate the

appropriate source code include line. Code to include other scripting code can be put directly in

In the Output File Extension field, type in .asp (or a different extension depending on your

needs).

the template or in blocks or stylesheets that are placed in template regions. Includes can even be

dynamically written out with XSLT based on input from the user in a data definition or system

asset. The benefit is that content from the system can be combined with custom programming to

create new opportunities.

B. Incorporate Scripting Include in Template

To modify the template with scripting include code:
1.
2.
3.

Go to the Home area.

Browse to a page that uses the desired template. In our case, we will select /web/about .
On the View tab of the page, click the Configurations pane to view the individual

configurations and their corresponding templates.

With the configurations and their templates displayed, click on the template to be modified.

In our case, we will select
/web/templates/standard from the
HTML configuration.

Now with the template displayed,
click the Edit tab.

For the XML field, scroll to the very
bottom and put in the appropriate
include code before the </body>
tag. For our ASP example, we will put
in:

<!l-- #include

file="authentication.asp" -->

Now click the Submit button to

record the template change.

13
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With the template updated, now you can publish out the content and it will have the appropriate file

extension and scripting language includes. Because the scripting language include won’t be

processed in the CMS, it is sometimes important to give the CMS user a visual clue that a specific

region of content will be different when it is published to the live server. The CMS supports
pseudo-tags whereby content is tagged as viewable internally in the CMS or externally when

content is published.

C. System View Internal and External

To incorporate the pseudo-tags for internal and external view, please do the following:
1. Browse to the appropriate template. In our case, we will select /web/templates/standard
2. Click the Edit tab.
3. Scroll to the bottom of the XML field area and just before the </body> tag, type the
following:
[system-view:internal]
<div align="center">Dynamic content is placed here on the published
server</div>
[/system-view:internal]
[system-view:external]
<!-- This appears in the published file -->
<!I-- #include file="script.asp" -->
[/system-view:external]

4. Click Submit to record the template changes.

Now, if you browse to a page that uses
the template, you'll see the content at
the bottom of the page. When you
publish the page, the resulting file won’t
have the notice and will have the include

for the actual dynamic code.

14
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lIl. METADATA SETS

Metadata sets provide a way to configure the standard metadata fields (e.qg. title, summary, author,

etc) and to add custom metadata fields to support user-defined taxonomies. Metadata sets can be

applied to pages, files, folders, blocks, and external links, allowing for custom metadata fields to be

included for selected assets. You want to create a new metadata set that requires the title field and

has a custom text field category.

A. Create a Metadata Set

To create a new metadata set:

1.

a w0

Go to the Administration area, and select Metadata Sets from the left navigation bar.
Click on New Metadata Set .

For the Name field, type in Require Title with Category

Go to the Wired Fields pane.

For Title, check the box for Required . The Visible , Hidden , and Inline fields are used to
determine if the field is shown

behind the metadata drop

down menu, removed

altogether, or shown inline with

content, respectively.

Go to the Dynamic Fields

pane.

Click Text to create a new

custom metadata field.

For the Name field, type in

Category . For the Field Label

field, type in Category .

Click the Submit button to

record the new metadata set.

The new metadata set has been created. To attach the metadata set to an asset, browse to the

asset in the system, click edit on the asset, then click the metadata button to show the metadata

fields, and finally choose and apply a hew metadata set.

15
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V. EXAMPLE MODULES

The database shipped with the CMS provides numerous examples. The following examples can be

found in the most recent production database and are updated regularly.

A. Alphabetical Listing

Example Location

Adobe InDesign ‘ /print-publications/InDesign

Announcement board ‘ /intranet/programs/examples/announcement

Blog entry ‘ /blogs/news/blog1

Data definition builder ‘ /common/data definitions/job posting

Document library ‘ /intranet/documents/default

E-learning ‘ /e-learning/courses/scorm/sco01

Employee directory ‘ /intranet/programs/examples/employee directory

Event calendar day view ‘ f/intranet/programs/calendar/2005/February/lincoln birthday

Event calendar month view ‘ /intranet/programs/calendar/2005/February/default

Folder summary ‘ f/intranet/programs/examples/default

Form creator ‘ /intranet/programs/examples/form

Frequently asked questions ‘ f/internet/solutions/web-content-management/faq

Job posting ‘ f/intranet/programs/examples/job posting

Jump menu ‘ f/intranet/programs/examples/jump menu

Landing (marketing) ‘ /internet/online marketing/landings/google-bg

Meeting announcements ‘ /intranet/programs/examples/meetings

Menu builder ‘ /intranet/programs/miscellaneous/menu builder/visual

Multi-lingual ‘ f/intranet/programs/unicode/multi-lingual

Newsletters ‘ /internet/company/news/newsletters

People profiles /intranet/programs/examples/people profiles

Policies and procedures /intranet/documents/policies_procedures.pdf

Press release /internet/company/news/press_releases

Project management ‘ /intranet/programs/examples/project mgmt

Proposals ‘ /proposals/rfp response/generic/lresponse

Purchase requisitions ‘ f/intranet/programs/examples/purchase requisition

Quality assurance ‘ /common/quality-assurance

QuarkXPress ‘ /print-publications/QuarkXPress

16
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Real estate listing /intranet/programs/miscellaneous/real estate

Requests internal/external ‘ f/intranet/programs/examples/request

RSS ‘ linternet/rss

SEO analysis ‘ /internet/online marketing/keywords/web-publishing

Site map ‘ /internet/site-map

Slide show f/intranet/programs/miscellaneous/slide show

Survey creator ‘ /intranet/programs/examples/survey

Thumbnails ‘ /intranet/programs/miscellaneous/thumbnails

Workflow builder /common/workflows

Thanks for completing the fifth Technical Introduction. Please let us know if we can answer any

guestions.
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